musl: update to the latest git version, fixes TLS issues
[openwrt/staging/chunkeey.git] / toolchain / musl / patches / 200-add_libssp_nonshared.patch
index 0b97b346f8435b8572646788d1b9343bef10cf56..f6758cdae845dfcdc53415d2d59745e0bf2925a9 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -56,7 +56,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
+@@ -60,7 +60,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
  STATIC_LIBS = lib/libc.a
  SHARED_LIBS = lib/libc.so
  TOOL_LIBS = lib/musl-gcc.specs
@@ -21,18 +21,18 @@ Signed-off-by: Steven Barth <steven@midlink.org>
  ALL_TOOLS = obj/musl-gcc
  
  WRAPCC_GCC = gcc
-@@ -117,7 +117,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
-       src/env/__libc_start_main.c src/env/__init_tls.c \
-       src/thread/__set_thread_area.c src/env/__stack_chk_fail.c \
-       src/string/memset.c src/string/memcpy.c \
--      src/ldso/dlstart.c src/ldso/dynlink.c
-+      src/ldso/dlstart.c src/ldso/dynlink.c \
+@@ -123,7 +123,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
+       src/thread/__set_thread_area.c src/thread/$(ARCH)/__set_thread_area.c \
+       src/string/memset.c src/string/$(ARCH)/memset.c \
+       src/string/memcpy.c src/string/$(ARCH)/memcpy.c \
+-      ldso/dlstart.c ldso/dynlink.c
++      ldso/dlstart.c ldso/dynlink.c \
 +      src/libssp_nonshared/__stack_chk_fail_local.c
  $(NOSSP_SRCS:%.c=obj/%.o) $(NOSSP_SRCS:%.c=obj/%.lo): CFLAGS_ALL += $(CFLAGS_NOSSP)
  
  $(CRT_LIBS:lib/%=obj/crt/%): CFLAGS_ALL += -DCRT
-@@ -161,6 +162,11 @@ lib/libc.a: $(OBJS)
-       $(AR) rc $@ $(OBJS)
+@@ -167,6 +168,11 @@ lib/libc.a: $(AOBJS)
+       $(AR) rc $@ $(AOBJS)
        $(RANLIB) $@
  
 +lib/libssp_nonshared.a: obj/src/libssp_nonshared/__stack_chk_fail_local.o