tools: automake: update to v1.15
[openwrt/staging/chunkeey.git] / tools / automake / Makefile
index 546f9b26619f272af9e65ce971ae54aa9de610ca..300bee21ea116831ffdf5d5f85a916a279c0d2d4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=automake
-PKG_VERSION:=1.11.6
+PKG_VERSION:=1.15
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/automake
-PKG_MD5SUM:=cf4752287ad708f83bd3689da57a32c9
+PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -19,6 +19,9 @@ HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
 HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
 
 define Host/Install
+       # remove old automake resources to avoid version conflicts
+       rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+       rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
        $(MAKE) -C $(HOST_BUILD_DIR) install
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
@@ -26,6 +29,7 @@ define Host/Install
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
+       ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
 endef
 
 define Host/Clean