use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/staging/chunkeey.git] / tools / m4 / Makefile
index 91efb5b0d5444fbe6df364f43438aa0d04b717b2..6470a549a59a3e128b4f2397ce7a73a4fde1d0ec 100644 (file)
@@ -16,7 +16,7 @@ PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall