squashfs: link statically
[openwrt/staging/chunkeey.git] / tools / squashfs / Makefile
index c6ad3dd1be363ee15fb3c0fcf70a3766cf8bcd7b..f4a546013551d05b1d492e927fe0b909c65e4c48 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
                CC="$(HOSTCC)" \
+               CXX="$(CXX) -static" \
                LZMAPATH=$(STAGING_DIR_HOST)/lib \
                mksquashfs-lzma unsquashfs-lzma 
 endef