tools/xz: Compile with PIC to fix linking errors
[openwrt/staging/chunkeey.git] / tools / xz / Makefile
index 5d574892bb02181f6c77c8073169c16a7ac64de4..21029a74aa0e0a5c709cfb85dd14cd025bc9b5c9 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -25,7 +25,8 @@ HOSTCXX := $(HOSTCXX_NOCACHE)
 HOST_CONFIGURE_ARGS += \
        --enable-static=yes \
        --enable-shared=no \
-       --disable-doc
+       --disable-doc \
+       --with-pic
 
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"