build: use config.site generated by autoconf-lean, drop hardcoded sitefiles
[openwrt/staging/dedeckeh.git] / Makefile
index aecee6929e29add4a161f70f5bfd80f7e02b8568..d3c51761e9f36b5ab00d7e101f8ec800cdc8d144 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -82,12 +82,6 @@ endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
-       @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
-               echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
-               echo '       The missing file will cause configure scripts to fail during compilation.'; \
-               echo '       Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
-               exit 1; \
-       fi
 
 $(BIN_DIR)/profiles.json: FORCE
        $(if $(CONFIG_JSON_OVERVIEW_IMAGE_INFO), \