build: introduce $(MKHASH)
[openwrt/staging/dedeckeh.git] / include / image-commands.mk
index afb2dde5ba3789247804551bd529e4fa2bce1705..fa368850388d095131245c796c0f644fa5d2eda6 100644 (file)
@@ -198,7 +198,7 @@ define Build/elx-header
                        dd bs=20 count=1 conv=sync; \
                echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
                        dd bs=8 count=1 conv=sync; \
-               echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+               echo -ne "$$($(MKHASH) md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
                        dd bs=58 count=1 conv=sync; \
        ) > $(KDIR)/tmp/$(DEVICE_NAME).header
        $(call Build/xor-image,-p $(xor_pattern) -x)