target: include selinux-variants if CONFIG_SELINUX is set
[openwrt/staging/dedeckeh.git] / include / target.mk
index 31ce592c8bb777848c49241114589390bc78ce56..a2e76f8149b739ddd3880faf7bb7103410f7a3ec 100644 (file)
@@ -15,7 +15,6 @@ DEVICE_TYPE?=router
 # Default packages - the really basic set
 DEFAULT_PACKAGES:=\
        base-files \
-       busybox \
        ca-bundle \
        dropbear \
        fstools \
@@ -30,6 +29,13 @@ DEFAULT_PACKAGES:=\
        uclient-fetch \
        urandom-seed \
        urngd
+
+ifneq ($(CONFIG_SELINUX),)
+DEFAULT_PACKAGES+=busybox-selinux procd-selinux
+else
+DEFAULT_PACKAGES+=busybox procd
+endif
+
 # For the basic set
 DEFAULT_PACKAGES.basic:=
 # For nas targets