move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the...
[openwrt/staging/dedeckeh.git] / openwrt / package / gdbserver / Makefile
diff --git a/openwrt/package/gdbserver/Makefile b/openwrt/package/gdbserver/Makefile
deleted file mode 100644 (file)
index 922e631..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gdbserver
-PKG_VERSION:=6.3
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,GDBSERVER,gdbserver,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-
-$(PKG_BUILD_DIR)/.prepared:
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
-       touch $@
-
-$(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               $(GDB_DIR)/gdb/gdbserver/configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --sbindir=/usr/sbin \
-                 --libexecdir=/usr/lib \
-                 --sysconfdir=/etc \
-                 --datadir=/usr/share \
-                 --localstatedir=/var \
-                 --mandir=/usr/man \
-                 --infodir=/usr/info \
-                 $(DISABLE_NLS) \
-                 $(DISABLE_LARGEFILE) \
-       );
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
-       touch $@
-
-$(IPKG_GDBSERVER):
-       install -m0755 -d $(IDIR_GDBSERVER)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(IDIR_GDBSERVER)/usr/bin/
-       $(RSTRIP) $(IDIR_GDBSERVER)
-       $(IPKG_BUILD) $(IDIR_GDBSERVER) $(PACKAGE_DIR)
-