move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the...
[openwrt/staging/dedeckeh.git] / openwrt / package / wol / Makefile
diff --git a/openwrt/package/wol/Makefile b/openwrt/package/wol/Makefile
deleted file mode 100644 (file)
index efdb670..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=wol
-PKG_VERSION:=0.7.1
-PKG_RELEASE:=1
-PKG_MD5SUM:=c2fa9d7e771134ac8c89d56b8197d4ca
-
-PKG_SOURCE_URL:=@SF/ahh
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,WOL,wol,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                 ac_cv_func_malloc_0_nonnull=yes \
-                 ac_cv_func_realloc_0_nonnull=yes \
-                 ac_cv_func_mmap_fixed_mapped=yes \
-                 jm_cv_func_working_malloc=yes \
-                 ac_cv_func_alloca_works=yes \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_NLS) \
-                 $(DISABLE_LARGEFILE) \
-       );
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-       touch $@
-
-$(IPKG_WOL):
-       install -m0755 -d $(IDIR_WOL)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wol $(IDIR_WOL)/usr/bin/
-       $(RSTRIP) $(IDIR_WOL)
-       $(IPKG_BUILD) $(IDIR_WOL) $(PACKAGE_DIR)