add new image builder
[openwrt/staging/dedeckeh.git] / openwrt / target / linux / image / squashfs.mk
index 70a85b99ee7445329e5f401c46b9f7707fda0e2c..42ff77db6455e6643932fa8fea34d50eb8411f62 100644 (file)
@@ -14,7 +14,13 @@ $(KDIR)/root.squashfs:
 
 squashfs-install: $(KDIR)/root.squashfs
        $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+
+squashfs-install-ib:
+       mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
+       cp $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
        
 prepare: squashfs-prepare
 compile: squashfs-compile
 install: squashfs-install
+install-ib: squashfs-install-ib
+clean: squashfs-clean