uboot-sunxi: update support for FriendlyARM ZeroPI
[openwrt/staging/dedeckeh.git] / package / boot / uboot-sunxi / patches / 250-sun8i-h3-zeropi-add-device-tree.patch
diff --git a/package/boot/uboot-sunxi/patches/250-sun8i-h3-zeropi-add-device-tree.patch b/package/boot/uboot-sunxi/patches/250-sun8i-h3-zeropi-add-device-tree.patch
deleted file mode 100644 (file)
index 152e608..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
---- a/arch/arm/dts/Makefile
-+++ b/arch/arm/dts/Makefile
-@@ -559,7 +559,8 @@ dtb-$(CONFIG_MACH_SUN8I_H3) += \
-       sun8i-h3-orangepi-plus.dtb \
-       sun8i-h3-orangepi-plus2e.dtb \
-       sun8i-h3-orangepi-zero-plus2.dtb \
--      sun8i-h3-rervision-dvk.dtb
-+      sun8i-h3-rervision-dvk.dtb \
-+      sun8i-h3-zeropi.dtb
- dtb-$(CONFIG_MACH_SUN8I_R40) += \
-       sun8i-r40-bananapi-m2-ultra.dtb \
-       sun8i-v40-bananapi-m2-berry.dtb
---- /dev/null
-+++ b/arch/arm/dts/sun8i-h3-zeropi.dts
-@@ -0,0 +1,66 @@
-+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-+
-+#include "sun8i-h3-nanopi.dtsi"
-+
-+/ {
-+      model = "FriendlyElec ZeroPi";
-+      compatible = "friendlyarm,zeropi", "allwinner,sun8i-h3";
-+
-+      aliases {
-+              ethernet0 = &emac;
-+      };
-+
-+      reg_gmac_3v3: gmac-3v3 {
-+              compatible = "regulator-fixed";
-+              pinctrl-names = "default";
-+              pinctrl-0 = <&gmac_power_pin_nanopi>;
-+              regulator-name = "gmac-3v3";
-+              regulator-min-microvolt = <3300000>;
-+              regulator-max-microvolt = <3300000>;
-+              startup-delay-us = <100000>;
-+              enable-active-high;
-+              gpio = <&pio 3 6 GPIO_ACTIVE_HIGH>;
-+      };
-+};
-+
-+&ehci0 {
-+      status = "okay";
-+};
-+
-+&ohci0 {
-+      status = "okay";
-+};
-+
-+&pio {
-+      gmac_power_pin_nanopi: gmac_power_pin@0 {
-+              pins = "PD6";
-+              function = "gpio_out";
-+      };
-+};
-+
-+&external_mdio {
-+      ext_rgmii_phy: ethernet-phy@1 {
-+              compatible = "ethernet-phy-ieee802.3-c22";
-+              reg = <7>;
-+      };
-+};
-+
-+&emac {
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&emac_rgmii_pins>;
-+      phy-supply = <&reg_gmac_3v3>;
-+      phy-handle = <&ext_rgmii_phy>;
-+      phy-mode = "rgmii";
-+
-+      allwinner,leds-active-low;
-+      status = "okay";
-+};
-+
-+&usb_otg {
-+      status = "okay";
-+      dr_mode = "peripheral";
-+};
-+
-+&usbphy {
-+      usb0_id_det-gpios = <&pio 6 12 GPIO_ACTIVE_HIGH>; /* PG12 */
-+};