kernel: crypto: crypto-rng: select SHA512 for >= 5.14.0
[openwrt/staging/dedeckeh.git] / package / kernel / linux / modules / crypto.mk
index 4950b94c62d019365e918a678b7785aeba2b0f98..98bcb9e874701195ffc9b25c6628077079f542f0 100644 (file)
@@ -827,7 +827,9 @@ $(eval $(call KernelPackage,crypto-rmd160))
 
 define KernelPackage/crypto-rng
   TITLE:=CryptoAPI random number generation
-  DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha256
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac \
+               +LINUX_5_10:kmod-crypto-sha256 \
+               +LINUX_5_15:kmod-crypto-sha512
   KCONFIG:= \
        CONFIG_CRYPTO_DRBG \
        CONFIG_CRYPTO_DRBG_HMAC=y \