ath79: Add Aruba AP-175 support
[openwrt/staging/dedeckeh.git] / target / linux / ath79 / image / generic.mk
index 608b51766fa4f969d752f8367b64dbb3fc878183..328861de037dc7eab93ea0252e85b7597ab40665 100644 (file)
@@ -395,6 +395,15 @@ define Device/aruba_ap-105
 endef
 TARGET_DEVICES += aruba_ap-105
 
+define Device/aruba_ap-175
+  SOC := ar7161
+  DEVICE_VENDOR := Aruba
+  DEVICE_MODEL := AP-175
+  IMAGE_SIZE := 16000k
+  DEVICE_PACKAGES := kmod-gpio-pca953x kmod-hwmon-lm75 kmod-i2c-gpio kmod-rtc-ds1374
+endef
+TARGET_DEVICES += aruba_ap-175
+
 define Device/asus_pl-ac56
   SOC := qca9563
   DEVICE_VENDOR := ASUS