kernel: bump 4.9 to 4.9.161
[openwrt/staging/dedeckeh.git] / target / linux / generic / hack-4.9 / 220-gc_sections.patch
index e326412d0e7523957729ea0c87df92b543d35e61..ea6ce0bcf7e105941bd605867e61b648e7f64592 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -406,6 +406,11 @@ KBUILD_CFLAGS_MODULE  := -DMODULE
+@@ -401,6 +401,11 @@ KBUILD_CFLAGS_MODULE  := -DMODULE
  KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
  GCC_PLUGINS_CFLAGS :=
  
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
  KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -673,11 +678,6 @@ KBUILD_CFLAGS     += $(call cc-disable-warni
+@@ -649,11 +654,6 @@ KBUILD_CFLAGS     += $(call cc-disable-warni
  KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
  KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)