ramips: add support for TOTOLINK LR1200
[openwrt/staging/dedeckeh.git] / target / linux / ramips / image / mt76x8.mk
index 4e6a5d1ca9b78175b023aafc1e1cf5082d384f38..2280a1a6180fc55f04a7d7e773551ae76258b1d0 100644 (file)
@@ -183,6 +183,14 @@ define Device/skylab_skw92a
 endef
 TARGET_DEVICES += skylab_skw92a
 
+define Device/totolink_lr1200
+  DTS := TOTOLINK-LR1200
+  IMAGE_SIZE := 7872k
+  DEVICE_TITLE := TOTOLINK LR1200
+  DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 uqmi
+endef
+TARGET_DEVICES += totolink_lr1200
+
 define Device/tplink_tl-wa801nd-v5
   $(Device/tplink)
   DTS := TL-WA801NDV5