toolchain: add gcc 7.1.0 support
[openwrt/staging/dedeckeh.git] / toolchain / gcc / common.mk
index 47767d53a94f65a9aacd9363651223c7c4917275..55ae1a2c09b3fcbf777335929ce62f4bc46ab72d 100644 (file)
@@ -36,6 +36,10 @@ ifeq ($(PKG_VERSION),6.3.0)
   PKG_HASH:=f06ae7f3f790fbf0f018f6d40e844451e6bc3b7bc96e128e63b09825c1f8b29f
 endif
 
+ifeq ($(PKG_VERSION),7.1.0)
+  PKG_HASH:=8a8136c235f64c6fef69cac0d73a46a1a09bb250776a050aec8f9fc880bebc17
+endif
+
 ifneq ($(CONFIG_GCC_VERSION_6_2_ARC),)
     PKG_VERSION:=6.2.1
     PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/$(GCC_VERSION)
@@ -71,7 +75,8 @@ HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.gcc_$(GCC_VARIANT)_installed
 SEP:=,
 TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
 
-TAR_OPTIONS += --exclude='gcc/testsuite/*' --exclude=gcc/ada/*.ad*
+TAR_OPTIONS += \
+       --exclude-from='$(CURDIR)/../exclude-testsuite' --exclude=gcc/ada/*.ad* \
 
 ifndef CONFIG_INSTALL_LIBGCJ
   TAR_OPTIONS += --exclude=libjava