toolchain/gcc: Add GCC 10.1.0 patches
[openwrt/staging/dedeckeh.git] / toolchain / gcc / patches / 10.1.0 / 820-libgcc_pic.patch
index 0a316d35bf684c96556d69cf601f9855d53a7631..ddd6cf873261f8438e6a7de9f5287a516a9f0e21 100644 (file)
@@ -8,7 +8,7 @@ Date:   Mon Oct 19 23:26:09 2009 +0000
 
 --- a/libgcc/Makefile.in
 +++ b/libgcc/Makefile.in
-@@ -927,11 +927,12 @@ $(libgcov-driver-objects): %$(objext): $
+@@ -929,11 +929,12 @@ $(libgcov-driver-objects): %$(objext): $
  
  # Static libraries.
  libgcc.a: $(libgcc-objects)
@@ -22,7 +22,7 @@ Date:   Mon Oct 19 23:26:09 2009 +0000
        -rm -f $@
  
        objects="$(objects)";                                   \
-@@ -955,7 +956,7 @@ all: libunwind.a
+@@ -957,7 +958,7 @@ all: libunwind.a
  endif
  
  ifeq ($(enable_shared),yes)
@@ -31,7 +31,7 @@ Date:   Mon Oct 19 23:26:09 2009 +0000
  ifneq ($(LIBUNWIND),)
  all: libunwind$(SHLIB_EXT)
  libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_EXT)
-@@ -1161,6 +1162,10 @@ install-shared:
+@@ -1163,6 +1164,10 @@ install-shared:
        chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
        $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a