strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt/staging/florian.git] / package / madwifi / Makefile
index 70177d960597dba45ee0a28f10d850efceb0015e..2770c3d68a7483a18ae573e964622b10cee2a7e7 100644 (file)
@@ -43,13 +43,10 @@ ifeq ($(ARCH),powerpc)
 endif
 
 BUS:=PCI
-ifneq ($(CONFIG_LINUX_2_6_ATHEROS),)
+ifneq ($(CONFIG_TARGET_ATHEROS),)
   BUS:=AHB
   HAL_TARGET:=ap51
 endif
-ifneq ($(CONFIG_LINUX_2_6_ARUBA),)
-  BUS:=PCI AHB # no suitable HAL for AHB yet.
-endif
 
 BUS_MODULES:=
 ifeq ($(findstring AHB,$(BUS)),AHB)