upgrade to the new version of wprobe - includes reconfigurable layer 2 statistics...
[openwrt/staging/florian.git] / package / wprobe / src / user / Makefile
index e10dfc0d24e9925f52bd74e03ff762e97b57efef..01e83da3ebd312a72465fb1ffb967505ef650204 100644 (file)
@@ -1,21 +1,38 @@
-CFLAGS = -O2
-CPPFLAGS ?= -I../kernel
-WFLAGS = -Wall -Werror
+include ../Makefile.inc
+
+CPPFLAGS += -I../kernel
 LDFLAGS =
 
+ifneq ($(HOST_OS),Linux)
+USE_LIBNL_MICRO=1
+else
+USE_LIBNL_MICRO=
+endif
+
+ifeq ($(USE_LIBNL_MICRO),1)
+LIBNL_PREFIX = /usr/local
+LIBNL = $(LIBNL_PREFIX)/lib/libnl-micro.a
+CPPFLAGS += -I$(LIBNL_PREFIX)/include/libnl-micro
+EXTRA_CFLAGS += -DNO_LOCAL_ACCESS
+else
 LIBNL = -lnl
+endif
+
 LIBM = -lm
 LIBS = $(LIBNL) $(LIBM)
 
-all: libwprobe.a wprobe-info
+all: libwprobe.a wprobe-util
 
-libwprobe.a: wprobe.o
+libwprobe.a: wprobe-lib.o
        rm -f $@
        $(AR) rcu $@ $^
        $(RANLIB) $@
 
 %.o: %.c
-       $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $<
+       $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $<
 
-wprobe-info: wprobe-info.o wprobe.o
+wprobe-util: wprobe-util.o wprobe-lib.o
        $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+clean:
+       rm -f *.o *.a wprobe-util