imagebuilder: remove existing root filesystem images
[openwrt/staging/florian.git] / target / imagebuilder / Makefile
index 8a7c2093b987e5e339138305f05bfd400f3b2174..13eed7e108ca27fd40c05b6e1de144ac53b5e9b0 100644 (file)
@@ -66,6 +66,7 @@ endif
                $(PKG_BUILD_DIR)/target/linux/*/patches{,-*}
        -cp $(KERNEL_BUILD_DIR)/* $(IB_KDIR)/ # don't copy subdirectories here
        -cp $(LINUX_DIR)/.config $(IB_LDIR)/
+       rm -f $(IB_KDIR)/root.*
        if [ -x $(LINUX_DIR)/scripts/dtc/dtc ]; then \
                $(INSTALL_DIR) $(IB_LDIR)/scripts/dtc; \
                $(INSTALL_BIN) $(LINUX_DIR)/scripts/dtc/dtc $(IB_LDIR)/scripts/dtc/dtc; \