add support for alternative C libraries (currently only glibc/eglibc) other (related...
[openwrt/staging/florian.git] / toolchain / glibc-ports / patches / 2.6.1 / 603-powerpc-softfloat.patch
diff --git a/toolchain/glibc-ports/patches/2.6.1/603-powerpc-softfloat.patch b/toolchain/glibc-ports/patches/2.6.1/603-powerpc-softfloat.patch
new file mode 100644 (file)
index 0000000..3213c9a
--- /dev/null
@@ -0,0 +1,21 @@
+From: http://sourceware.org/ml/crossgcc/2008-10/msg00044.html
+From: http://sources.redhat.com/ml/libc-ports/2007-06/msg00005.html
+
+2007-06-07  Steven Munroe  <sjmunroe@us.ibm.com>
+
+    * sysdeps/powerpc/nofpu/Makefile: Remove fe_nomask from libm-support.
+
+diff -urN glibc-ports-2.6.1.orig/sysdeps/powerpc/nofpu/Makefile glibc-ports-2.6.1/sysdeps/powerpc/nofpu/Makefile
+--- glibc-ports-2.6.1.orig/sysdeps/powerpc/nofpu/Makefile      2006-11-22 09:13:11.000000000 -0600
++++ glibc-ports-2.6.1/sysdeps/powerpc/nofpu/Makefile   2007-06-07 09:53:05.708240976 -0500
+@@ -6,7 +6,7 @@
+ endif
+ ifeq ($(subdir),math)
+-libm-support += fenv_const fe_nomask
++libm-support += fenv_const
+ CPPFLAGS += -I../soft-fp/
+ # The follow CFLAGS are a work around for GCC Bugzilla Bug 29253
+ # "expand_abs wrong default code for floating point"
+
+