bison: make yacc wrapper relocatable
[openwrt/staging/florian.git] / tools / bison / patches / 000-relocatable.patch
diff --git a/tools/bison/patches/000-relocatable.patch b/tools/bison/patches/000-relocatable.patch
new file mode 100644 (file)
index 0000000..f83bb1e
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -77,6 +77,7 @@ MOSTLYCLEANFILES = yacc
+ yacc:
+       echo '#! /bin/sh' >$@
++      echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+       echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+       chmod a+x $@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1352,6 +1352,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+ yacc:
+       echo '#! /bin/sh' >$@
++      echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+       echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+       chmod a+x $@