sunxi: Orange Pi R1 SPI: add spi flash board
[openwrt/staging/hauke.git] / package / boot / uboot-sunxi / Makefile
index b3d9c1eb69a700a3a63fdb7f9b96eae002c367bc..ae43c043272c761a66804fd1d86fb1517aebddd0 100644 (file)
@@ -156,6 +156,12 @@ define U-Boot/orangepi_pc
   BUILD_DEVICES:=sun8i-h3-orangepi-pc
 endef
 
+define U-Boot/orangepi_r1_spi
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Orange Pi R1 (H2+) (boot from SPI)
+  BUILD_DEVICES:=sun8i-h2-plus-orangepi-r1-spi
+endef
+
 define U-Boot/orangepi_plus
   BUILD_SUBTARGET:=cortexa7
   NAME:=Orange Pi Plus (H3)
@@ -248,6 +254,7 @@ UBOOT_TARGETS := \
        nanopi_neo2 \
        orangepi_r1 \
        orangepi_pc \
+       orangepi_r1_spi \
        orangepi_plus \
        orangepi_2 \
        orangepi_pc2 \