move boot related packages to their own folder
[openwrt/staging/jogo.git] / package / boot / uboot-xburst / patches / 009-n516.patch
diff --git a/package/boot/uboot-xburst/patches/009-n516.patch b/package/boot/uboot-xburst/patches/009-n516.patch
new file mode 100644 (file)
index 0000000..49eaf3d
--- /dev/null
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index ed848f5..04cd32e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3448,6 +3448,18 @@ pavo_nand_config        :       unconfig
+       @echo "TEXT_BASE = 0x80100000" > $(obj)board/qi_lb60/config.tmp
+       @echo "CONFIG_NAND_U_BOOT = y" >> $(obj)include/config.mk
++n516_config           :       unconfig
++      @ >include/config.h
++      @echo "#define CONFIG_N516 1" >>include/config.h
++      @./mkconfig -a n516 mips mips n516
++
++n516_nand_config      :       unconfig
++      @echo "#define CONFIG_NAND_U_BOOT" > $(obj)include/config.h
++      @echo "Compile NAND boot image for n516"
++      @./mkconfig -a n516 mips mips n516
++      @echo "TEXT_BASE = 0x80100000" > $(obj)board/n516/config.tmp
++      @echo "CONFIG_NAND_U_BOOT = y" >> $(obj)include/config.mk
++
+ #########################################################################
+ ## MIPS64 5Kc
+ #########################################################################