gdb: bump to 8.2
[openwrt/staging/jogo.git] / package / devel / gdb / patches / 110-shared_libgcc.patch
index 84d1f60f2fe01140ab27a24d5aa5c84c7250dc8d..c8ddfde5cca908f208fc9078413f8293304bdd71 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1293,13 +1293,13 @@ if test -z "$LD"; then
+@@ -1277,13 +1277,13 @@ if test -z "$LD"; then
    fi
  fi
  
    fi
  fi
  
@@ -15,9 +15,9 @@
 +  LDFLAGS="$LDFLAGS -static-libstdc++"
 +  AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
    AC_LANG_PUSH(C++)
 +  LDFLAGS="$LDFLAGS -static-libstdc++"
 +  AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
    AC_LANG_PUSH(C++)
-   AC_LINK_IFELSE([
+   AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1625,7 +1625,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1609,7 +1609,7 @@ AC_ARG_WITH(stage1-ldflags,
   # if supported.  But if the user explicitly specified the libraries to use,
   # trust that they are doing what they want.
   if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
   # if supported.  But if the user explicitly specified the libraries to use,
   # trust that they are doing what they want.
   if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
   fi])
  AC_SUBST(stage1_ldflags)
  
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1654,7 +1654,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1638,7 +1638,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
  
 --- a/configure
 +++ b/configure
-@@ -4998,14 +4998,14 @@ if test -z "$LD"; then
+@@ -5043,14 +5043,14 @@ if test -z "$LD"; then
    fi
  fi
  
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -5788,7 +5788,7 @@ else
+@@ -5833,7 +5833,7 @@ else
   # if supported.  But if the user explicitly specified the libraries to use,
   # trust that they are doing what they want.
   if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
   # if supported.  But if the user explicitly specified the libraries to use,
   # trust that they are doing what they want.
   if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
   fi
  fi
  
-@@ -5824,7 +5824,7 @@ else
+@@ -5869,7 +5869,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then