bmips: remove linux 5.10 compatibility
[openwrt/staging/ldir.git] / target / linux / bmips / patches-5.10 / 602-pci-controllers-add-bcm6318-pcie-support.patch
diff --git a/target/linux/bmips/patches-5.10/602-pci-controllers-add-bcm6318-pcie-support.patch b/target/linux/bmips/patches-5.10/602-pci-controllers-add-bcm6318-pcie-support.patch
deleted file mode 100644 (file)
index 3674028..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/drivers/pci/controller/Kconfig
-+++ b/drivers/pci/controller/Kconfig
-@@ -3,6 +3,11 @@
- menu "PCI controller drivers"
-       depends on PCI
-+config PCIE_BCM6318
-+      bool "BCM6318 PCIe controller"
-+      depends on BMIPS_GENERIC || COMPILE_TEST
-+      depends on OF
-+
- config PCIE_BCM6328
-       bool "BCM6328 PCIe controller"
-       depends on BMIPS_GENERIC || COMPILE_TEST
---- a/drivers/pci/controller/Makefile
-+++ b/drivers/pci/controller/Makefile
-@@ -1,4 +1,5 @@
- # SPDX-License-Identifier: GPL-2.0
-+obj-$(CONFIG_PCIE_BCM6318) += pcie-bcm6318.o
- obj-$(CONFIG_PCIE_BCM6328) += pcie-bcm6328.o
- obj-$(CONFIG_PCIE_CADENCE) += cadence/
- obj-$(CONFIG_PCI_FTPCI100) += pci-ftpci100.o