package/uboot-omap: re-introduce patches dropped by update to v2017.01 TODO: add...
[openwrt/staging/lynxis/omap.git] / package / boot / uboot-omap / patches / 103-disable-fat-write-spl.patch
diff --git a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
new file mode 100644 (file)
index 0000000..89b0204
--- /dev/null
@@ -0,0 +1,27 @@
+Index: u-boot-2017.01/fs/fat/Makefile
+===================================================================
+--- u-boot-2017.01.orig/fs/fat/Makefile
++++ u-boot-2017.01/fs/fat/Makefile
+@@ -4,8 +4,8 @@
+ #
+ obj-$(CONFIG_FS_FAT)  := fat.o
+-obj-$(CONFIG_FAT_WRITE):= fat_write.o
+ ifndef CONFIG_SPL_BUILD
++obj-$(CONFIG_FAT_WRITE):= fat_write.o
+ obj-$(CONFIG_FS_FAT)  += file.o
+ endif
+Index: u-boot-2017.01/fs/fat/fat.c
+===================================================================
+--- u-boot-2017.01.orig/fs/fat/fat.c
++++ u-boot-2017.01/fs/fat/fat.c
+@@ -163,7 +163,7 @@ static void get_name(dir_entry *dirent,
+ }
+ static int flush_dirty_fat_buffer(fsdata *mydata);
+-#if !defined(CONFIG_FAT_WRITE)
++#if !defined(CONFIG_FAT_WRITE) || defined(CONFIG_SPL_BUILD)
+ /* Stub for read only operation */
+ int flush_dirty_fat_buffer(fsdata *mydata)
+ {