iproute2: fix compile with uClibc-ng
[openwrt/staging/lynxis/omap.git] / package / network / utils / iproute2 / Makefile
index 23834dfd243888821b5661e89782d6071597dafc..f5b5f4e536b13f989159dad92a6c6e439facd496 100644 (file)
@@ -84,6 +84,9 @@ endif
 ifdef CONFIG_USE_MUSL
   TARGET_CFLAGS += -DHAVE_SETNS
 endif
+ifdef CONFIG_UCLIBC_USE_VERSION_NG
+  TARGET_CFLAGS += -DHAVE_SETNS
+endif
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections