cns3xxx: remove linux 4.4 support
[openwrt/staging/lynxis/omap.git] / target / linux / cns3xxx / patches-4.4 / 070-i2c_support.patch
diff --git a/target/linux/cns3xxx/patches-4.4/070-i2c_support.patch b/target/linux/cns3xxx/patches-4.4/070-i2c_support.patch
deleted file mode 100644 (file)
index 6645ff6..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/i2c/busses/Kconfig
-+++ b/drivers/i2c/busses/Kconfig
-@@ -440,6 +440,18 @@ config I2C_CBUS_GPIO
-         This driver can also be built as a module.  If so, the module
-         will be called i2c-cbus-gpio.
-+config I2C_CNS3XXX
-+      tristate "Cavium CNS3xxx I2C driver"
-+      depends on ARCH_CNS3XXX
-+      help
-+        Support for Cavium CNS3xxx I2C controller driver.
-+
-+        This driver can also be built as a module.  If so, the module
-+        will be called i2c-cns3xxx.
-+
-+        Please note that this driver might be needed to bring up other
-+        devices such as Cavium CNS3xxx Ethernet.
-+
- config I2C_CPM
-       tristate "Freescale CPM1 or CPM2 (MPC8xx/826x)"
-       depends on CPM1 || CPM2
---- a/drivers/i2c/busses/Makefile
-+++ b/drivers/i2c/busses/Makefile
-@@ -111,6 +111,7 @@ obj-$(CONFIG_I2C_VIPERBOARD)       += i2c-vipe
- obj-$(CONFIG_I2C_ACORN)               += i2c-acorn.o
- obj-$(CONFIG_I2C_BCM_KONA)    += i2c-bcm-kona.o
- obj-$(CONFIG_I2C_BRCMSTB)     += i2c-brcmstb.o
-+obj-$(CONFIG_I2C_CNS3XXX)     += i2c-cns3xxx.o
- obj-$(CONFIG_I2C_CROS_EC_TUNNEL)      += i2c-cros-ec-tunnel.o
- obj-$(CONFIG_I2C_ELEKTOR)     += i2c-elektor.o
- obj-$(CONFIG_I2C_OPAL)                += i2c-opal.o