mvebu: remove linux 4.4 support
[openwrt/staging/lynxis/omap.git] / target / linux / mvebu / patches-4.4 / 129-phy-add-I2C-mdio-bus.patch
diff --git a/target/linux/mvebu/patches-4.4/129-phy-add-I2C-mdio-bus.patch b/target/linux/mvebu/patches-4.4/129-phy-add-I2C-mdio-bus.patch
deleted file mode 100644 (file)
index 13f8ecf..0000000
+++ /dev/null
@@ -1,163 +0,0 @@
-From 7f36ac946bfbd4090b8b94be3661b41ac73e21f4 Mon Sep 17 00:00:00 2001
-From: Russell King <rmk+kernel@arm.linux.org.uk>
-Date: Fri, 25 Sep 2015 17:43:52 +0100
-Subject: [PATCH 717/744] phy: add I2C mdio bus
-
-Add an I2C MDIO bus bridge library, to allow phylib to access PHYs which
-are connected to an I2C bus instead of the more conventional MDIO bus.
-Such PHYs can be found in SFP adapters and SFF modules.
-
-Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
----
- drivers/net/phy/Kconfig    | 10 ++++++
- drivers/net/phy/Makefile   |  1 +
- drivers/net/phy/mdio-i2c.c | 90 ++++++++++++++++++++++++++++++++++++++++++++++
- drivers/net/phy/mdio-i2c.h | 19 ++++++++++
- 4 files changed, 120 insertions(+)
- create mode 100644 drivers/net/phy/mdio-i2c.c
- create mode 100644 drivers/net/phy/mdio-i2c.h
-
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -233,6 +233,16 @@ config MDIO_GPIO
-         To compile this driver as a module, choose M here: the module
-         will be called mdio-gpio.
-+config MDIO_I2C
-+      tristate
-+      depends on I2C
-+      help
-+        Support I2C based PHYs.  This provides a MDIO bus bridged
-+        to I2C to allow PHYs connected in I2C mode to be accessed
-+        using the existing infrastructure.
-+
-+        This is library mode.
-+
- config MDIO_OCTEON
-       tristate "Support for MDIO buses on Octeon and ThunderX SOCs"
-       depends on 64BIT
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -41,6 +41,7 @@ obj-$(CONFIG_SWCONFIG_B53)   += b53/
- obj-$(CONFIG_FIXED_PHY)               += fixed_phy.o
- obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o
- obj-$(CONFIG_MDIO_GPIO)               += mdio-gpio.o
-+obj-$(CONFIG_MDIO_I2C)                += mdio-i2c.o
- obj-$(CONFIG_NATIONAL_PHY)    += national.o
- obj-$(CONFIG_DP83640_PHY)     += dp83640.o
- obj-$(CONFIG_DP83848_PHY)     += dp83848.o
---- /dev/null
-+++ b/drivers/net/phy/mdio-i2c.c
-@@ -0,0 +1,90 @@
-+/*
-+ * MDIO I2C bridge
-+ *
-+ * Copyright (C) 2015 Russell King
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License version 2 as
-+ * published by the Free Software Foundation.
-+ */
-+#include <linux/i2c.h>
-+#include <linux/phy.h>
-+
-+#include "mdio-i2c.h"
-+
-+static int i2c_mii_read(struct mii_bus *bus, int phy_id, int reg)
-+{
-+      struct i2c_adapter *i2c = bus->priv;
-+      struct i2c_msg msgs[2];
-+      u8 data[2], dev_addr = reg;
-+      int bus_addr, ret;
-+
-+      bus_addr = 0x40 + phy_id;
-+      if (bus_addr == 0x50 || bus_addr == 0x51)
-+              return 0xffff;
-+
-+      msgs[0].addr = bus_addr;
-+      msgs[0].flags = 0;
-+      msgs[0].len = 1;
-+      msgs[0].buf = &dev_addr;
-+      msgs[1].addr = bus_addr;
-+      msgs[1].flags = I2C_M_RD;
-+      msgs[1].len = sizeof(data);
-+      msgs[1].buf = data;
-+
-+      ret = i2c_transfer(i2c, msgs, ARRAY_SIZE(msgs));
-+      if (ret != ARRAY_SIZE(msgs))
-+              return 0xffff;
-+
-+      return data[0] << 8 | data[1];
-+}
-+
-+static int i2c_mii_write(struct mii_bus *bus, int phy_id, int reg, u16 val)
-+{
-+      struct i2c_adapter *i2c = bus->priv;
-+      struct i2c_msg msg;
-+      int bus_addr, ret;
-+      u8 data[3];
-+
-+      bus_addr = 0x40 + phy_id;
-+      if (bus_addr == 0x50 || bus_addr == 0x51)
-+              return 0;
-+
-+      data[0] = reg;
-+      data[1] = val >> 8;
-+      data[2] = val;
-+
-+      msg.addr = bus_addr;
-+      msg.flags = 0;
-+      msg.len = 3;
-+      msg.buf = data;
-+
-+      ret = i2c_transfer(i2c, &msg, 1);
-+
-+      return ret < 0 ? ret : 0;
-+}
-+
-+struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter *i2c)
-+{
-+      struct mii_bus *mii;
-+
-+      if (!i2c_check_functionality(i2c, I2C_FUNC_I2C))
-+              return ERR_PTR(-EINVAL);
-+
-+      mii = mdiobus_alloc();
-+      if (!mii)
-+              return ERR_PTR(-ENOMEM);
-+
-+      snprintf(mii->id, MII_BUS_ID_SIZE, "i2c:%s", dev_name(parent));
-+      mii->parent = parent;
-+      mii->read = i2c_mii_read;
-+      mii->write = i2c_mii_write;
-+      mii->priv = i2c;
-+
-+      return mii;
-+}
-+EXPORT_SYMBOL_GPL(mdio_i2c_alloc);
-+
-+MODULE_AUTHOR("Russell King");
-+MODULE_DESCRIPTION("MDIO I2C bridge library");
-+MODULE_LICENSE("GPL v2");
---- /dev/null
-+++ b/drivers/net/phy/mdio-i2c.h
-@@ -0,0 +1,19 @@
-+/*
-+ * MDIO I2C bridge
-+ *
-+ * Copyright (C) 2015 Russell King
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License version 2 as
-+ * published by the Free Software Foundation.
-+ */
-+#ifndef MDIO_I2C_H
-+#define MDIO_I2C_H
-+
-+struct device;
-+struct i2c_adapter;
-+struct mii_bus;
-+
-+struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter *i2c);
-+
-+#endif