tools: build GNU date from coreutils on non-Linux systems
[openwrt/staging/lynxis/omap.git] / tools / Makefile
index abf5b043eba98899e0e3f3f623fe102a16ece5f6..f7a731619b0cc61b8f5e500d9dca609dab5903e5 100644 (file)
@@ -84,6 +84,9 @@ tools-y += libressl
 $(curdir)/mkimage/compile += $(curdir)/libressl/install
 $(curdir)/firmware-utils/compile += $(curdir)/libressl/install
 endif
+ifneq ($(HOST_OS),Linux)
+  tools-y += coreutils
+endif
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
 $(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))