add gcc-4.5.0 preliminary support
[openwrt/staging/lynxis/omap.git] / tools / mpc / Makefile
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
new file mode 100644 (file)
index 0000000..3898830
--- /dev/null
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.8.1
+
+PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=5b34aa804d514cc295414a963aedb6bf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-mpfr=$(TOPDIR)/staging_dir/host \
+       --with-gmp=$(TOPDIR)/staging_dir/host
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR)/$(3); \
+               $(HOST_CONFIGURE_CMD) \
+               $(HOST_CONFIGURE_VARS) \
+               $(HOST_CONFIGURE_ARGS); \
+       )
+endef
+
+
+$(eval $(call HostBuild))