add a hacked up version of upslug2 which is able to flash a wrt350nv2 in recovery...
[openwrt/staging/lynxis/omap.git] / tools / upslug2 / Makefile
diff --git a/tools/upslug2/Makefile b/tools/upslug2/Makefile
new file mode 100644 (file)
index 0000000..6a73853
--- /dev/null
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=upslug2
+PKG_VERSION:=20071227
+
+PKG_SOURCE_URL:=http://svn.nslu2-linux.org/svnroot/upslug2/trunk
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_SUBDIR:=upslug2-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=41
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); \
+               aclocal && autoconf && \
+               autoheader && \
+               automake --add-missing; \
+       )
+       $(Host/Configure/Default)
+endef
+
+ifneq ($(HOST_OS),Linux)
+       HOST_CONFIGURE_ARGS += --with-libpcap
+endif
+
+$(eval $(call HostBuild))