add the 'ead' package (emergency access daemon), which can provide remote access...
[openwrt/staging/mkresin.git] / package / ead / Makefile
diff --git a/package/ead/Makefile b/package/ead/Makefile
new file mode 100644 (file)
index 0000000..280b51d
--- /dev/null
@@ -0,0 +1,53 @@
+# 
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ead
+PKG_RELEASE:=1
+
+PKG_BUILD_DEPENDS:=pcap
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ead
+  SECTION:=net
+  CATEGORY:=Base system
+  TITLE:=Emergency Access Daemon
+  URL:=http://bridge.sourceforge.net/
+endef
+
+define Package/ead/description
+  Provides remote access to your device even if IP and firewall
+  configuration settings are defunct
+endef
+
+CONFIGURE_PATH = tinysrp
+
+TARGET_CFLAGS += \
+       -I$(PKG_BUILD_DIR) \
+       -I$(PKG_BUILD_DIR)/tinysrp \
+       -I$(STAGING_DIR)/usr/include
+
+MAKE_FLAGS += \
+       CONFIGURE_ARGS="$(CONFIGURE_ARGS)" \
+       LIBS="$(PKG_BUILD_DIR)/tinysrp/libtinysrp.a" \
+       LIBS_EAD="$(PKG_BUILD_DIR)/tinysrp/libtinysrp.a $(STAGING_DIR)/usr/lib/libpcap.a" \
+       CFLAGS="$(TARGET_CFLAGS)"
+
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/ead/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ead $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,ead))