kernel: 5.15: add new module
[openwrt/staging/mkresin.git] / package / kernel / linux / modules / input.mk
index e870bf7f8bef2c3a5c6888f0fef4e6b60c27fc74..e052a7afac1a3b6bea38b0c400ab6b22c92e76be 100644 (file)
@@ -179,10 +179,10 @@ define KernelPackage/input-touchscreen-ads7846
   DEPENDS:=+kmod-hwmon-core +kmod-input-core +kmod-spi-bitbang
   KCONFIG:= \
        CONFIG_INPUT_TOUCHSCREEN=y \
-       CONFIG_TOUCHSCREEN_PROPERTIES=y \
+       CONFIG_TOUCHSCREEN_PROPERTIES=y@lt5.13 \
        CONFIG_TOUCHSCREEN_ADS7846
   FILES:=$(LINUX_DIR)/drivers/input/touchscreen/ads7846.ko \
-       $(LINUX_DIR)/drivers/input/touchscreen/of_touchscreen.ko
+       $(LINUX_DIR)/drivers/input/touchscreen/of_touchscreen.ko@lt5.13
   AUTOLOAD:=$(call AutoProbe,ads7846)
 endef