kernel: Add snd-intel-nhlt.ko to kmod-sound-hda-intel
[openwrt/staging/mkresin.git] / package / kernel / linux / modules / sound.mk
index a49ba6da6a817584257d9a859839ea3c60334b9c..f975103e508cb96c110cbc6b24c410bc125cdb05 100644 (file)
@@ -502,11 +502,13 @@ $(eval $(call KernelPackage,sound-hda-codec-hdmi))
 define KernelPackage/sound-hda-intel
   SUBMENU:=$(SOUND_MENU)
   TITLE:=HD Audio Intel Driver
+  DEPENDS:=@TARGET_x86
   KCONFIG:= \
        CONFIG_SOUND_PCI \
        CONFIG_SND_HDA_INTEL
   FILES:= \
-       $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko
+       $(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
+       $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko@ge5.4
   AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
   $(call AddDepends/sound,kmod-sound-hda-core)
 endef