build: remove GCC7 support
[openwrt/staging/mkresin.git] / rules.mk
index 8b24d3a3bb416e4f39365052d9f9136e716caf9f..45b58614f1f5fb42c56d587e6daf85072054e124 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -138,11 +138,7 @@ else
 endif
 
 ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_TARGET_uml)),)
-  ifeq ($(CONFIG_GCC_USE_IREMAP),y)
-    iremap = -iremap$(1):$(2)
-  else
-    iremap = -f$(if $(CONFIG_REPRODUCIBLE_DEBUG_INFO),file,macro)-prefix-map=$(1)=$(2)
-  endif
+  iremap = -f$(if $(CONFIG_REPRODUCIBLE_DEBUG_INFO),file,macro)-prefix-map=$(1)=$(2)
 endif
 
 PACKAGE_DIR:=$(BIN_DIR)/packages