ath79: add support for Yuncore A930
[openwrt/staging/mkresin.git] / target / linux / ath79 / image / generic.mk
index 33a72358b3ac6b33535fa901213431874af2bee6..dc85fb60bfb81297bc00f98ae7ceafd188cc1d63 100644 (file)
@@ -2528,6 +2528,16 @@ define Device/yuncore_a782
 endef
 TARGET_DEVICES += yuncore_a782
 
+define Device/yuncore_a930
+  SOC := qca9533
+  DEVICE_VENDOR := YunCore
+  DEVICE_MODEL := A930
+  IMAGE_SIZE := 16000k
+  IMAGES += tftp.bin
+  IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
+endef
+TARGET_DEVICES += yuncore_a930
+
 define Device/yuncore_xd3200
   SOC := qca9563
   DEVICE_VENDOR := YunCore