mvebu: move subtarget image Makefile switch to parent Makefile
[openwrt/staging/mkresin.git] / target / linux / mvebu / image / Makefile
index ce1344a5470e8b74f4a7c6347b6c488e8d898764..6dd7bde7ae73c646812b64b1e2ab5a902f1ea179 100644 (file)
@@ -116,8 +116,16 @@ define Device/NAND-512K
   PAGESIZE := 4096
 endef
 
+ifeq ($(SUBTARGET),cortexa9)
 include cortex-a9.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
 include cortex-a53.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa72)
 include cortex-a72.mk
+endif
 
 $(eval $(call BuildImage))