build: label kernel and rootfs ext4 volumes
[openwrt/staging/mkresin.git] / target / linux / mvebu / image / Makefile
index b4b77b70b4b8746f44a4ecb209b80711838284a0..967a1e4ee1525ec9db9197c3d5ac13a8ef1c1810 100644 (file)
@@ -38,7 +38,7 @@ define Build/boot-img-ext4
        $(foreach dts,$(DEVICE_DTS), $(CP) $(KDIR)/image-$(dts).dtb $@.boot/$(dts).dtb;)
        $(CP) $(IMAGE_KERNEL) $@.boot/$(KERNEL_NAME)
        -$(CP) $@-boot.scr $@.boot/boot.scr
-       make_ext4fs -J -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
+       make_ext4fs -J -L kernel -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
 endef
 
 define Build/sdcard-img