mvebu: image: keep global DTS_DIR intact
[openwrt/staging/mkresin.git] / target / linux / mvebu / image / Makefile
index aeabffdca2c27d78633670a15633e9be69747599..d73f3e20fcc1585abe1947b10a7154f5f5ca1ac6 100644 (file)
@@ -78,6 +78,7 @@ endef
 define Device/Default
   PROFILES := Default
   DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+  DEVICE_DTS_DIR := $(DTS_DIR)
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
@@ -93,7 +94,7 @@ DEVICE_VARS += BOOT_SCRIPT UBOOT
 
 define Device/Default-arm64
   BOOT_SCRIPT := generic-arm64
-  DTS_DIR := $(DTS_DIR)/marvell
+  DEVICE_DTS_DIR := $(DTS_DIR)/marvell
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
   KERNEL_NAME := Image