ramips: add support for OrayBox X3A
[openwrt/staging/mkresin.git] / target / linux / ramips / image / mt7621.mk
index 3b34c9d364f1eb6c98169e28746a88439112d2e0..e15c1ec3a8d20039dfce8babf303204bbfa72d04 100644 (file)
@@ -1388,6 +1388,16 @@ define Device/netis_wf2881
 endef
 TARGET_DEVICES += netis_wf2881
 
+define Device/oraybox_x3a
+  $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
+  IMAGE_SIZE := 15360k
+  DEVICE_VENDOR := OrayBox
+  DEVICE_MODEL := X3A
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += oraybox_x3a
+
 define Device/phicomm_k2p
   $(Device/dsa-migration)
   IMAGE_SIZE := 15744k