ramips: add support for TOTOLINK X5000R
[openwrt/staging/mkresin.git] / target / linux / ramips / image / mt7621.mk
index 274d9f7158f4d3461a81bfe4c0f45db19c978142..7a97f8aa73d154ae37666e420e315a955ed61759 100644 (file)
@@ -1015,6 +1015,16 @@ define Device/totolink_a7000r
 endef
 TARGET_DEVICES += totolink_a7000r
 
+define Device/totolink_x5000r
+  $(Device/dsa-migration)
+  IMAGE_SIZE := 16064k
+  UIMAGE_NAME := C8343R-9999
+  DEVICE_VENDOR := TOTOLINK
+  DEVICE_MODEL := X5000R
+  DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += totolink_x5000r
+
 define Device/tplink_re350-v1
   $(Device/dsa-migration)
   $(Device/tplink-safeloader)