use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/staging/mkresin.git] / tools / ccache / Makefile
index 5d464e7ded5f75acba2c0be67b2de4d558076452..9020c9c47b64d81c6ee0f9ca7c77dbfdb10fcfef 100644 (file)
@@ -16,7 +16,7 @@ PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
 
 define Host/Install/ccache