gcc/binutils: disable sysv style hash tables for generated binaries
[openwrt/staging/nbd.git] / toolchain / gcc / common.mk
index cdbf9fafa9474b94f60d7defeb8f8ec1661f3180..48c4ba40f2e946e918268c5ad9870fbb5a3825fd 100644 (file)
@@ -104,6 +104,7 @@ GCC_CONFIGURE:= \
                --disable-libssp \
                $(GRAPHITE_CONFIGURE) \
                --with-host-libstdcxx=-lstdc++ \
+               $(if $(findstring mips,$(ARCH)),,--with-linker-hash-style=gnu) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \