uboot-at91: use sdmmc0 as booting media for sama5d27_som1_ek
[openwrt/staging/stintel.git] / target / linux / at91 / image / sama5.mk
index 9078db525f97750455dbee266e4b37fbd28ea9b8..d108d27908eabc0d1b9b165cce44bae369ca2e42 100644 (file)
@@ -15,23 +15,17 @@ define Build/at91-sdcard
        $(KDIR)/$(DEVICE_NAME)-fit-zImage.itb \
        ::$(DEVICE_NAME)-fit.itb
 
-  $(if $(findstring sama5d27-som1-ek,$@), \
-      mcopy -i $@.boot \
-          $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc1/u-boot.bin \
-          ::u-boot.bin
-      mcopy -i $@.boot \
-          $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd1_uboot/at91bootstrap.bin \
-          ::BOOT.bin,
-      mcopy -i $@.boot \
-          $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc/u-boot.bin \
-          ::u-boot.bin
+  mcopy -i $@.boot \
+       $(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc/u-boot.bin \
+       ::u-boot.bin
+
       $(if $(findstring sama5d4-xplained,$@), \
           mcopy -i $@.boot \
               $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
               ::BOOT.bin,
           mcopy -i $@.boot \
               $(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot/at91bootstrap.bin \
-              ::BOOT.bin))
+              ::BOOT.bin)
 
   $(CP) uboot-env.txt $@-uboot-env.txt
   sed -i '2d;3d' $@-uboot-env.txt