rules.mk: move DOWNLOAD_CHECK_CERTIFICATE to include/download.mk
[openwrt/staging/wigyori.git] / include / download.mk
index 76bd374cf7e349f31196401725c170df9262cf88..9ff71540f756ff5e6980a86e944917d7e05e601b 100644 (file)
@@ -18,6 +18,9 @@ endif
 
 DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
+# Export options for download.pl
+export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+
 define dl_method_git
 $(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)
 endef