build: image: add pad-to and pad-rootfs-squashfs helpers
[openwrt/staging/wigyori.git] / include / image.mk
index 530a2b1335a83bb31f8de0b796c37ca67a21f2cb..3680be2155d361b898b78df62547eb457caa5457 100644 (file)
@@ -178,6 +178,15 @@ ifeq ($(strip $(call kernel_patchver_ge,4.18.0)),1)
        -Wno-unique_unit_address
 endif
 
+define Image/pad-to
+       dd if=$(1) of=$(1).new bs=$(2) conv=sync
+       mv $(1).new $(1)
+endef
+
+define Image/pad-root-squashfs
+       $(call Image/pad-to,$(KDIR)/root.squashfs,$(if $(1),$(1),$(CONFIG_TARGET_ROOTFS_PARTSIZE)M))
+endef
+
 # $(1) source dts file
 # $(2) target dtb file
 # $(3) extra CPP flags