kernel: remove further obsolete kernel version switches
[openwrt/staging/wigyori.git] / include / image.mk
index 26da4d68193ea6653b0cc74562a56d4e5991a58f..46d592e8dca872ddf02b28be0e1a6e5c966b6d2d 100644 (file)
@@ -157,18 +157,13 @@ endif
 
 
 # Disable noisy checks by default as in upstream
-ifeq ($(strip $(call kernel_patchver_ge,4.7.0)),1)
-  DTC_FLAGS += -Wno-unit_address_vs_reg
-endif
-ifeq ($(strip $(call kernel_patchver_ge,4.12.0)),1)
-  DTC_FLAGS += \
-       -Wno-unit_address_vs_reg \
-       -Wno-simple_bus_reg \
-       -Wno-unit_address_format \
-       -Wno-pci_bridge \
-       -Wno-pci_device_bus_num \
-       -Wno-pci_device_reg
-endif
+DTC_FLAGS += \
+  -Wno-unit_address_vs_reg \
+  -Wno-simple_bus_reg \
+  -Wno-unit_address_format \
+  -Wno-pci_bridge \
+  -Wno-pci_device_bus_num \
+  -Wno-pci_device_reg
 ifeq ($(strip $(call kernel_patchver_ge,4.17.0)),1)
   DTC_FLAGS += \
        -Wno-avoid_unnecessary_addr_size \